Back to overview
Resolved

Mailgun is experiencing an outage (Outbound Delivery)

May 25, 2026 at 1:40pm UTC
Affected services
Outbound Email

Resolved
May 25, 2026 at 3:50pm UTC

Outbound Delivery has recovered and is now operational — source: status.mailgun.com

Created
May 25, 2026 at 1:40pm UTC

Outbound Delivery may be affected — source: status.mailgun.com